yr server run only 127.0.0.1

i have same issue  

first when install wamp server  and try to

run localhost  it’s  fail and write forbidden 

but when run 127.0.0.1  accepted 

and i note that when run phpmyadmin ir run on link  –>>  localhost/phpmyadmin  and 127.0.0.1/phpmyadmin

 

simple solution for this issue  

rirght click on wamp beside yr clock  then choose apache –>>httpd.conf and find  this block : 

 

<Directory “c:/wamp/www/”>
#

# onlineoffline tag – don’t remove
Order Deny,Allow
Deny from all
Allow from 127.0.0.1

</Directory>

 i   bold this line Allow from 127.0.0.1   

you must change it into    Allow from all 

 

we solve localhost issue   but wait  there are another issue we need to resolve phpmyadmin 

and make it run from  localhost/phpmyadmin   plus 127.0.0.1/phpmyadmin

simply right click on wamp again and choose apache —>>aliasdir —->>localhost/phpmyadmin/  –>> edit alias 

 

you will find 

<Directory “c:/wamp/apps/phpmyadmin3.4.5/”>

…………………..
AllowOverride all
Order Deny,Allow
Deny from all
Allow from 127.0.0.1
</Directory>

 

change bold line to 

Allow from all

 

save and exit  

Don’t forget restart yr server   🙂 

Advertisements
Posted in php

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s